3

I have discovered an answered question with a wrong answer. I've found it initially googling by myself to an answer to it, and I've fixed it. Also I've tried to do what an answer suggests - and it is NOT working. I've posted my working answer as a comment - how can I add my correct answer, so other googling people won't be misguided by wrong answer accepted?

4

You have an account with 101 rep on the main site. The "protected" banner says:

This question is protected to prevent "thanks!", "me too!", or spam answers by new users. To answer it, you must have earned at least 10 reputation on this site.

However, there is a subtlety here in the wording, "earned". The 100 bonus you receive for being a member elsewhere on Stack Exchange doesn't count in this instance:

Who can answer a protected question?

Users with 10 or more reputation can answer a protected question. However, the +100 account association bonus is ignored for this check, so you must have earned 10 or more reputation on that specific site to answer a protected question.

Since you don't have that, the "protected" restriction applies to you. You then have a couple of options:

  • Be satisfied with the comment you left; in my opinion in this case that's sufficient. The comment is clear and at the top (except for one brief thing above it). Anyone who reads the answer will see it. The person who wrote the answer is not active here anymore, but s/he is active on S.O. so would have received notification of your comment by now.

  • Post your own question and provide your own answer -- if you do this, be sure to differentiate it somehow from this one. E.g., you've implied that the documentation itself in this configuration file is wrong. Is it still the same on Jessie? I could not find this file in that location on a current Jessie lite image, so I can't say, but it seems something has changed. I checked on another site where I have the same 101 rep and there is the "Answer your own question" tickbox at the bottom of the "Ask Question" page, these are encouraged (presuming you make good use of the mechanism).

  • Since this is a gray area cross-over topic with Unix & Linux, which has a much larger user base and available expertise on this kind of issue, you could ask about it there. Hopefully, the issue would then be definitively settled, and you could add another comment with a link to that question, which would be more likely to attract the OP's attention and that of the general reader (particularly someone who's looking for a solution to a problem).

Note that you cannot edit other people's posts arbitrarily without approval until you have 2000 rep. However, editing a wrong answer to say "EDIT: This is wrong", or (worse) to substantially change the content because you think it is wrong is absolutely inappropriate regardless of reputation. You use comments or you add your own answer, in which you are free to reference other existing answers you believe are wrong.

You can also use flags if you believe something deserves moderator attention, and in extreme cases, feel free to access the chat, where currently there is pretty much always one mod or another lurking around whom you can ping for attention.

  • thanks, I've already downvoted it, actually it does not give me to downvote(it changes for a second from 7 to 6 but turns back), I've posted the right solution as a comment from the very beginning, now I've flagged it, I hope it helps – Alexey Vesnin Jan 29 '16 at 20:47
  • Keep in mind there's a canned response we can/should use, something like "Flags are not to be used for altogether wrong answers". That's not how the site works. Rightness and wrongness are not dictated by moderator fiat. All you can do is leave your opinion and cross your fingers, it is up to the author. BTW I believe the problem w/ that answer may have to do with a change that was made with Raspbian jessie, notice that answer is 2013. – goldilocks Jan 29 '16 at 20:51
  • actually, I've checked it - it's completely DHCPD-dependent, so under FreeBSD it works the same way, checked it too. A part of it's grounds is at the official Git source : "# No service will be given on this subnet, but declaring it helps the 25 # DHCP server to understand the network topology. 26 27 subnet 10.152.187.0 netmask 255.255.255.0 { 28 }" – Alexey Vesnin Jan 29 '16 at 21:07
  • I always disable it and just use dhclient, so I am ignorant regarding this particular labyrinth. – goldilocks Jan 29 '16 at 21:09
  • it's a server, so if you need to obtain IP address from a router - you're correct in disabling it. I'm using it to give IP addresses to my hostapd-based Wi-Fi network. And this time it was a problem with config file. It took me a while to investigate it to it's source, and it is just about NOT comparing networks, but defining them ALL in dhcpd.conf : every network must have it's own corresponding subnet clause – Alexey Vesnin Jan 29 '16 at 21:25
  • Sounds like you should post an answer... – goldilocks Jan 29 '16 at 21:27
  • but the question is "write-protected" =( That's why I've started this question on Meta – Alexey Vesnin Jan 29 '16 at 21:40
  • Scroll to the bottom of the page. There is an answer box. Write your answer. Click "Post Your Answer" when you are satisfied. If that's really not there, let me know and I'll investigate. – goldilocks Jan 29 '16 at 21:42
  • Not there : "protected by Jivings Apr 30 '14 at 14:43 Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site. Would you like to answer one of these unanswered questions instead?" – Alexey Vesnin Jan 29 '16 at 22:33
  • But you have 101 rep :\ Are you logged in properly? (Sorry if that's patronizing, I have to ask of course.). If so something is wrong. I can ask around, but I won't really have time until tomorrow. If you get it to work out, lemme know, otherwise I'll try and have more for you within 24 hours. It shouldn't be like this. – goldilocks Jan 30 '16 at 0:01
  • Yes I'm logged in properly, site works just fine. But the question seems to be an answer-protected, so I can't post a correct answer. And it's not a quest for correctness : the DHCP server is quite a frequent task people need, and it's an important element of server/router, and the answer selected there is not working. So I don't want other people get in trouble – Alexey Vesnin Jan 30 '16 at 3:34
  • Okay, here's the reason: "Users with 10 or more reputation can answer a protected question. However, the +100 account association bonus is ignored for this check, so you must have earned 10 or more reputation on that specific site". I've edited that in (and some options), sorry for having wasted both our time here (really it is ambiguous in the banner, "earned on this site", but "we gave you 100 and it doesn't count"). – goldilocks Jan 30 '16 at 12:12
  • Earning 10 rep isn't that hard, although this site in particular is very stingy E.g., I notice you've been a member here 6 months but only voted twice, presumably one of them the down on that answer :( Not saying that's karma but...to be trite, sometimes the consequences of our own actions only becomes clear when we suffer them ourselves. – goldilocks Jan 30 '16 at 12:14
  • Thanks for clarifying the situation! It should be explicitly said in a help center, I think - to avoid such kind of situations. I'll do my best to earn 10 rep, and after posting an answer - I'll post here to let you know is it OK. – Alexey Vesnin Jan 30 '16 at 14:52
  • Added an answer with full details, worked OK =) Thanks again for your help! – Alexey Vesnin Feb 1 '16 at 15:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .